Speedo LEDs ? Anyone used them?

Post Reply

Topic Author
Fuch77
Registered user
Posts: 256
Joined: Mon Apr 10, 2017 8:15 pm

Speedo LEDs ? Anyone used them?

Post by Fuch77 » Sun Feb 24, 2019 9:27 pm

Hello all.
The illumination in my speedo is very dim now. Has anyone used the LEDs from ebay?
Are they much of a upgrade brightness wise?
https://www.ebay.co.uk/itm/VW-Splitscre ... :rk:1:pf:0


58splitty
Registered user
Posts: 743
Joined: Wed May 18, 2011 7:52 pm
Location: Brandon, Suffolk
Contact:

Re: Speedo LEDs ? Anyone used them?

Post by 58splitty » Sun Feb 24, 2019 9:50 pm

1958 splitscreen
1969 custom bug (the only bug to have been on the cover of Volksworls and Ultra VW)
1972 roof chopped bug (volksword, street machine, custom car, vw scene)

My invention: www.tapepal.co.uk
New website: www.radialdesign.co.uk

User avatar

vwJim
SSVC Committee Member
SSVC Committee Member
Posts: 19808
Joined: Thu Apr 24, 2003 6:05 pm
Location: under a bus in Hampshire...
Contact:

Re: Speedo LEDs ? Anyone used them?

Post by vwJim » Sun Feb 24, 2019 11:33 pm

Be aware. If you use LED's then your battery might not charge correctly, as the system requires the load from the 2w lamp to work correctly.
Supplying quality in house designed items plus parts from SyncLink, Kennedy Clutches, & CB Performance. Also fitting service including modifications & mechanical upgrades.

User avatar

Who.Me?
SSVC Member
SSVC Member
Posts: 989
Joined: Thu May 15, 2014 8:13 pm
Location: West Sussex

Re: Speedo LEDs ? Anyone used them?

Post by Who.Me? » Mon Feb 25, 2019 6:26 pm

Fuch77 wrote:
Sun Feb 24, 2019 9:27 pm
Hello all.
The illumination in my speedo is very dim now.
Have you tried turning the knob on the light switch? VW made the gauge lights dimmable by turning the on/off switch knob. I thought mine were terrible until I read that and realised they were turned all the way down. :oops:


Topic Author
Fuch77
Registered user
Posts: 256
Joined: Mon Apr 10, 2017 8:15 pm

Re: Speedo LEDs ? Anyone used them?

Post by Fuch77 » Mon Feb 25, 2019 6:55 pm

I did know but its a good point to make. Mine are dim when fully turned up and also out around half way down. Im sure they never used to be that dim. Is there a upgrade thats not LEDS?

User avatar

clymoj
Registered user
Posts: 1355
Joined: Tue Mar 27, 2012 12:10 pm
Location: London & Birmingham

Re: Speedo LEDs ? Anyone used them?

Post by clymoj » Mon Feb 25, 2019 10:54 pm

If they go out halfway down then your resistance wire on your light switch may have a break in it. My old switch did that so I just bypassed it to run my dash lights on permanent full brightness until I can get my spare switch repaired.

Worth piggy backing the 58b dash light wire onto the 58 headlight terminal to check.

Then you can be sure that no they really are that dim even on full - it’s to make sure your eyes are adjusted so you can still see the road with the rubbish headlight beam.


Sent from my iPhone using Tapatalk
Image

User avatar

clymoj
Registered user
Posts: 1355
Joined: Tue Mar 27, 2012 12:10 pm
Location: London & Birmingham

Re: Speedo LEDs ? Anyone used them?

Post by clymoj » Mon Feb 25, 2019 10:59 pm

To help with your actual question (I think you had a question didn’t you?) it might be worth contacting http://www.dynamoregulatorconversions.com/ and explaining your challenge.

They sold me a special indicator relay which accounts for the fact that flash speed normally needs the correct bulb resistance and manages to still flash correctly even with LED rear lights. I’m pretty sure they’d sell you a resistor to add into the circuit and the appropriate LED replacement bulbs too.


Sent from my iPhone using Tapatalk
Image

User avatar

Who.Me?
SSVC Member
SSVC Member
Posts: 989
Joined: Thu May 15, 2014 8:13 pm
Location: West Sussex

Re: Speedo LEDs ? Anyone used them?

Post by Who.Me? » Tue Feb 26, 2019 1:24 pm

Before I realised it was the switch, I tried LEDs from ebay. They were brighter, but I didn't like them.

The original poster is welcome to whichever ones I have FOC, if he pays the postage. (Fuch77, if you want them, PM me.) The 'tell tale' bulbs are coloured to match the filters in the speedo.

I took them back out and refitted the incandescent bulbs. I like being able to dim them now I know that's how they're supposed to work.

Fix the switch or check the wires first though.


Topic Author
Fuch77
Registered user
Posts: 256
Joined: Mon Apr 10, 2017 8:15 pm

Re: Speedo LEDs ? Anyone used them?

Post by Fuch77 » Thu Mar 28, 2019 7:12 pm

Gentleman thank you ALL for your advice.
Clymoj it turns out you were right the dimmer in the switch is broken. ( so if anyone knows of a working one for sale? Genuine please)
I chose not to fit LED in the end as I agree with Who.me and like the fact they dim. I used to amuse myself turning them up and down sometimes.
Who.me mate It was a very Kind offer to send them to me but i wont take it up.
I did fit a LED to the blue main beam bulb as that has not worked for years so will update this thread is i get charging problems like Vw jim said could happen.
I really got my moneys worth with the blue LED as its is almost as bright as the headlamps and so i had to put a vw pin over it to stop it dazzling me
Attachments
55786345_2207125012884733_3002063530087153664_n.jpg
55575671_2259684867614420_8862783547803435008_n.jpg
55575671_2259684867614420_8862783547803435008_n.jpg (27.27 KiB) Viewed 504 times

User avatar

clymoj
Registered user
Posts: 1355
Joined: Tue Mar 27, 2012 12:10 pm
Location: London & Birmingham

Re: Speedo LEDs ? Anyone used them?

Post by clymoj » Fri Mar 29, 2019 4:11 am

Glad you got it sorted. I have three light switches with broken dimmers, none with a working one though sadly


Sent from my iPhone using Tapatalk
Image

Post Reply