Alternator Help Please

Post Reply
MrCheezy
Registered user
Posts: 35
Joined: Sun Dec 24, 2017 7:37 am

Alternator Help Please

Post by MrCheezy »

I've got a few issues with the alternator (std 55 amp but with no markings?} on my 67 bus. It was fitted when I got it so don't know the history.

It all started when the red light started flashing whilst driving at about 1500rpm but going out above this and then sometimes would not come on with the ignition turned on. I have checked the belt and checked the wiring including a new earth to the alternator. I checked the brushes and they look fine and hardly worn, i took a peek where the brushes go and the copper rings (commutators?) also look fine. I cleaned them with a contact cleaner and reassembled. From my voltmeter the output of the alternator looks intermittent sometimes good at 14v and then 12.4v. I have got good power from the red light blue wire (D+?) and the red light comes on when its earthed as you would expect. I measured the resistance from the D+ terminal on the alternator when the red light wouldn't come on and it read about 1050 ohms with the engine off which seem high?

So does this sound like a voltage regulator problem, new brushes or new alternator? I can remove it and get it tested at a local specialist but if its just the regulator i'd go for that first. I'll try and get some pics to help.

Appreciate any words of wisdom!

slammedpickup
Registered user
Posts: 323
Joined: Wed Jan 02, 2008 8:59 pm
Location: SOUTHEAST

Re: Alternator Help Please

Post by slammedpickup »

does it have the internal regulator?

User avatar
Sjtw
SSVC Member
SSVC Member
Posts: 1247
Joined: Sat Aug 11, 2012 9:12 pm
Location: Hertfordshire

Re: Alternator Help Please

Post by Sjtw »

Post a pick of the alternator.
If all your wiring to the bulb in the front is ok then it’s probably the regulator, some alternators have a section on top under the band that holds the to the post that can be removed and new regulator fitted. Otherwise it’s get a new one.
Steve

User avatar
vwJim
SSVC Committee Member
SSVC Committee Member
Posts: 19990
Joined: Thu Apr 24, 2003 6:05 pm
Location: under a bus in Hampshire...
Contact:

Re: Alternator Help Please

Post by vwJim »

It'll be the regulator. They're the common fault. Pretty easy straight swap just check which one before ordering as there's 2-3 types.
Supplying quality in house designed items plus parts from SyncLink, Kennedy Clutches, & CB Performance. Also fitting service including modifications & mechanical upgrades.

MrCheezy
Registered user
Posts: 35
Joined: Sun Dec 24, 2017 7:37 am

Re: Alternator Help Please

Post by MrCheezy »

Ok next stupid question, whats the easyest way to remove the alternator leaving the engine in?

Ive got a twin carb set up. Can I just loosen the pedestal nuts, and undo the 4 bolts that attached to the fan shroud (you can just see one behind the throttle linkage bar in the pic), remove the throttle linkage and the coil and pull the alternator and fan up from the studs and out?

Ive attached a pic to help.
Attachments
IMG_2671.JPG

User avatar
vwJim
SSVC Committee Member
SSVC Committee Member
Posts: 19990
Joined: Thu Apr 24, 2003 6:05 pm
Location: under a bus in Hampshire...
Contact:

Re: Alternator Help Please

Post by vwJim »

Disconnect the battery. Move your coil. Remove the linkage bar, undo the alternator strap, then remove the four screws and remove. Depending on what fan it is, sometimes it'll slide out, or you have to lift the fan housing up to get a bit more space.
Supplying quality in house designed items plus parts from SyncLink, Kennedy Clutches, & CB Performance. Also fitting service including modifications & mechanical upgrades.

MrCheezy
Registered user
Posts: 35
Joined: Sun Dec 24, 2017 7:37 am

Re: Alternator Help Please

Post by MrCheezy »

Thanks Jim, spot on.

I had to remove the pedestal in the end to get the clearance but no dramas. Voltage regulator on order.

MrCheezy
Registered user
Posts: 35
Joined: Sun Dec 24, 2017 7:37 am

Re: Alternator Help Please

Post by MrCheezy »

Hi just reassembling and noticed there is a large gap between the fan and the backing plate. The manual says .07 inch (2mm) but my gap is about 10mm!

The is a large spacer on the back of the alternator that if it wasn't there the fan hub would rub against the back of the alternator.

Is a 10mm gap acceptable or will I be loosing cooling effect? I have attached some pics to help
Attachments
IMG_2854.JPG
IMG_2856.JPG
IMG_2858.JPG

User avatar
vwJim
SSVC Committee Member
SSVC Committee Member
Posts: 19990
Joined: Thu Apr 24, 2003 6:05 pm
Location: under a bus in Hampshire...
Contact:

Re: Alternator Help Please

Post by vwJim »

Too much, it'll probably rub on the fan housing
Supplying quality in house designed items plus parts from SyncLink, Kennedy Clutches, & CB Performance. Also fitting service including modifications & mechanical upgrades.

Post Reply