Search found 104 matches

by jamusbass
Wed Jun 20, 2018 1:42 pm
Forum: Technical
Topic: Charge Warning Light not illuminating & no charge
Replies: 6
Views: 476

Re: Charge Warning Light not illuminating & no charge

Just bypassed the warning light circuit, my alternator is toast.

Thanks for the replies 👍
by jamusbass
Wed Jun 20, 2018 10:13 am
Forum: Technical
Topic: Charge Warning Light not illuminating & no charge
Replies: 6
Views: 476

Re: Charge Warning Light not illuminating & no charge

I’ve changed the bulb.. cheers!
by jamusbass
Wed Jun 20, 2018 9:55 am
Forum: Technical
Topic: Charge Warning Light not illuminating & no charge
Replies: 6
Views: 476

Re: Charge Warning Light not illuminating & no charge

Does the cluster have a common feed and does the signal wire back to the alternator carry a voltage or is it just an earth?

Jamie
by jamusbass
Wed Jun 20, 2018 9:53 am
Forum: Technical
Topic: Charge Warning Light not illuminating & no charge
Replies: 6
Views: 476

Re: Charge Warning Light not illuminating & no charge

Belt tension is good, the live terminal to the battery/starter is secure and the signal wire is attached.

Cheers!
by jamusbass
Wed Jun 20, 2018 9:40 am
Forum: Technical
Topic: Charge Warning Light not illuminating & no charge
Replies: 6
Views: 476

Charge Warning Light not illuminating & no charge

Looking for some pointers, As tiltle suggests, the charge warning light on the dash ain't working, Ive put a meter across the battery and it's no getting a charge. Hopefully its not the alternator, any suggestions would be much appreciated! I've checked the bulb and connections under the dash, all s...
by jamusbass
Mon Aug 01, 2016 9:53 pm
Forum: Bus Parts For Sale
Topic: Vintage Speed Shifter & OG Big Nut Rear Brake Drums
Replies: 9
Views: 1716

Re: Vintage Speed Shifter & OG Big Nut Rear Brake Drums

Sorry not been on for a while. I've still got the shifter.
by jamusbass
Fri Jul 15, 2016 10:31 pm
Forum: Bus Parts For Sale
Topic: Vintage Speed Shifter & OG Big Nut Rear Brake Drums
Replies: 9
Views: 1716

Re: Vintage Speed Shifter & OG Big Nut Rear Brake Drums

I would do £150 delivered?
by jamusbass
Tue Jul 12, 2016 10:34 am
Forum: Bus Parts For Sale
Topic: Vintage Speed Shifter & OG Big Nut Rear Brake Drums
Replies: 9
Views: 1716

Re: Vintage Speed Shifter & OG Big Nut Rear Brake Drums

jamusbass wrote:As above, came out my 61, is fitted with an Ivory knob.

£150 plus P&P or collection from EH510ne.


Brake DrumS - Sold
Can get pictures on request.
by jamusbass
Wed Jul 06, 2016 12:56 pm
Forum: Pointless Bitching
Topic: Know it all's
Replies: 38
Views: 4057

Know it all's

Actually know .... all.
by jamusbass
Tue Jul 05, 2016 5:44 pm
Forum: Bus Parts For Sale
Topic: Vintage Speed Shifter & OG Big Nut Rear Brake Drums
Replies: 9
Views: 1716

Vintage Speed Shifter & OG Big Nut Rear Brake Drums

As above, came out my 61, is fitted with an Ivory knob.

£150 plus P&P or collection from EH510ne.


Brake Drums - Sold
by jamusbass
Tue May 03, 2016 2:40 pm
Forum: Technical
Topic: Tow Bar with Vintage Speed Exhaust
Replies: 34
Views: 3691

Re: Tow Bar with Vintage Speed Exhaust

I've still not got round to it mate. I phoned autocraft a while back and they said it "should" work but no guarantees.

Keep me posted :)
by jamusbass
Mon Mar 07, 2016 8:47 pm
Forum: Technical
Topic: Bus Not Starting
Replies: 7
Views: 951

Re: Bus Not Starting

Just been along to my bus tonight, I noticed when I took the plugs out that one side was wet and the other dry. Seems like the needle valve might be sticking open on one side and not allowing the other carb to get fuel across? Just a guess to be honest. When I sprayed carb cleaner down the 'dry' sid...
by jamusbass
Sun Mar 06, 2016 9:17 am
Forum: Technical
Topic: Bus Not Starting
Replies: 7
Views: 951

Re: Bus Not Starting

Hopefully it's just a combination of running rich, short journeys and Scottish winters!

When I get it running it idles and pulls sweet.

Thanks for the replies folks!

J
by jamusbass
Sat Mar 05, 2016 7:11 pm
Forum: Technical
Topic: Bus Not Starting
Replies: 7
Views: 951

Re: Bus Not Starting

Won't start at all.

I can get it to run if I clean the plugs..
by jamusbass
Sat Mar 05, 2016 2:48 pm
Forum: Technical
Topic: Bus Not Starting
Replies: 7
Views: 951

Bus Not Starting

My bus has developed a cold starting fault over the last few weeks. It's a brand new 1915 build, reconditioned DRLA carbs, new concept racing fuel tank, Blue coil and Bosch 009. It used to start first turn but after sitting for a month it would't start - I cleaned the plugs and away it went first tu...